Avoir un aperçu de son site sous différentes configurations

Voilà un truc très utile si vous développez vous même le thème de votre blog. En effet, faire une version qui fonctionne sous firefox est aisée mais assurer la compatibilité avec Internet Explorer en version 6.0, 7.0, avec les navigateurs fonctionnant sous mac : Safari, et les autres firefox sous mac, IE pour mac…

En gros c’est un vrai casse tête. Voici donc trois sites vous permettant de valider visuellement ce que vous avez fait sous toutes les configurations possibles et inimaginables.

-On commence avec Browsrcamp qui va vous permettre de valider le site sous safari 2.0.4, le site est basique mais le résultat immédiat.

-Ensuite je vous propose BrowserShots.org qui est lui aussi gratuit mais qui propose bcp plus de possibilités d’environnements :

# Linux: Dillo 0.8, Epiphany 2.14, Epiphany 2.16, Firebird 0.6, Firebird 0.7, Firefox 1.0, Firefox 1.5, Firefox 2.0, Firefox 3.0, Flock 0.7, Galeon 2.0, Iceweasel 2.0, Konqueror 3.5, Mozilla 1.0, Mozilla 1.1, Mozilla 1.2, Mozilla 1.3, Mozilla 1.4, Mozilla 1.5, Mozilla 1.6, Mozilla 1.7, Navigator 4.8, Opera 9.2, Opera 9.10, Phoenix 0.1, Phoenix 0.2, Phoenix 0.3, Phoenix 0.4, Phoenix 0.5, SeaMonkey 1.0, SeaMonkey 1.1

# Mac: Firefox 2.0, Safari 2.0

Le seul soucis c’est qu’il faut attendre parfois très longtemps, et moi quand je fais un truc je veux que cela soit immédiat pour faire mes corrections.

-Voici donc LA solution ultime : BrowserCam mais qui est malheureusement payant, sauf car il y a tjs un sauf… vous avez la possibilité de l’utiliser 24 heures sans rien débourser et 24 heures c’est largement suffisant pour valider et faire des corrections. Comme le service est payant le résultat est immédiat et les configurations d’environnements sont énormes.

browsercam

Maintenant vous n’aurez plus aucune raison de ne pas avoir un site ne fonctionnant pas sous IE!

Articles en rapport :

3 Comments

  • 1
    Sharky
    March 4, 2007 - 11:37 pm | Permalink

    Il existe aussi un petit logiciel qui se nomme “MultipleIEs” qui permet d’installer IE3 IE4.01 IE5 IE5.5 et IE6 en plus de de IE7

    On peut le trouver à cette adresse gratuitement : http://tredosoft.com/Multiple_IE

  • 2
    March 5, 2007 - 11:12 am | Permalink

    Il y a aussi Danvine (iCapture et IeCapture)

    http://www.danvine.com/icapture/

    http://www.danvine.com/iecapture/

  • 3
    March 5, 2007 - 3:27 pm | Permalink

    Tu as raison je les ai oublié!